Comment activer IonCube

IonCube est un module qui permet de faire fonctionner les sites web encodé avec IonCube

Pour PHP4

PHP4 ne supporte pas la gestion des multiples php.ini.
IonCube est activé par défaut.

Pour PHP5 (5.2.x)

IonCube dans le perso.ini global
Il faut ajouter les lignes si-dessous à la fin du fichier perso.ini principal situé dans /cgi-bin/php5/perso.ini
[zend_extension]
zend_extension = /usr/local/etc/php5/ioncube_loader_lin_5.so
IonCube dans le php.ini du dossier courant
Il faut ajouter les lignes si-dessous à la fin du fichier php.ini situé dans le même dossier que le script PHP
[zend_extension]
zend_extension = /usr/local/etc/php5/ioncube_loader_lin_5.so

Pour PHP5 (5.3.x)

IonCube dans le perso.ini global
Il faut ajouter les lignes si-dessous à la fin du fichier perso.ini principal situé dans /cgi-bin/php5.3/perso.ini
[zend_extension]
zend_extension = /usr/local/etc/php5.3/ioncube_loader_lin_5.so
IonCube dans le php.ini du dossier courant
Il faut ajouter les lignes si-dessous à la fin du fichier php.ini situé dans le même dossier que le script PHP
[zend_extension]
zend_extension = /usr/local/etc/php5.3/ioncube_loader_lin_5.so

Pour PHP5 (5.4.x)

IonCube dans le perso.ini global
Il faut ajouter les lignes si-dessous à la fin du fichier perso.ini principal situé dans /cgi-bin/php5.4/perso.ini
[zend_extension]
zend_extension = /usr/local/etc/php5.4/ioncube_loader_lin_5.so
IonCube dans le php.ini du dossier courant
Il faut ajouter les lignes si-dessous à la fin du fichier php.ini situé dans le même dossier que le script PHP
[zend_extension]
zend_extension = /usr/local/etc/php5.4/ioncube_loader_lin_5.so

Pour PHP6 (6.0.x)

IonCube n'est pas supporté actuellement avec PHP6
Lorsque que celui-ci sera supporté, il faudra faire la même opération qu'avec PHP5 mais remplacer
"/usr/local/etc/php5/ioncube_loader_lin_5.so" par "/usr/local/etc/php6/ioncube_loader_lin_6.so"

Pour PHP6 (6.1.x)

IonCube n'est pas supporté actuellement avec PHP6
Lorsque que celui-ci sera supporté, il faudra faire la même opération qu'avec PHP5 mais remplacer
"/usr/local/etc/php5/ioncube_loader_lin_5.so" par "/usr/local/etc/php6.1/ioncube_loader_lin_6.so"