Comment activer ZenOptimizer de PHP

ZendOptimizer est un module qui permet de faire fonctionner les sites web encodé avec ZendGuard

Pour PHP4

PHP4 ne supporte pas la gestion des multiples php.ini.
ZendOptimizer est activé par défaut.

Pour PHP5

ZendOptimizer dans le perso.ini global
PHP 5.2.x Il faut ajouter les lignes si-dessous à la fin du fichier perso.ini principal situé dans /cgi-bin/php5/perso.ini
PHP 5.3.x Il faut ajouter les lignes si-dessous à la fin du fichier perso.ini principal situé dans /cgi-bin/php5.3/perso.ini
PHP 5.4.x Il faut ajouter les lignes si-dessous à la fin du fichier perso.ini principal situé dans /cgi-bin/php5.4/perso.ini
[Zend]
zend_extension_manager.optimizer=/usr/local/Zend/lib/Optimizer-3.3.9
zend_extension_manager.optimizer_ts=/usr/local/Zend/lib/Optimizer_TS-3.3.9
zend_optimizer.version=3.3.9
zend_extension=/usr/local/Zend/lib/ZendExtensionManager.so
zend_extension_ts=/usr/local/Zend/lib/ZendExtensionManager_TS.so
ZendOptimizer dans le php.ini du dossier courant
Il faut ajouter les lignes si-dessous à la fin du fichier php.ini principal situé dans le même dossier que le script PHP
[Zend]
zend_extension_manager.optimizer=/usr/local/Zend/lib/Optimizer-3.3.9
zend_extension_manager.optimizer_ts=/usr/local/Zend/lib/Optimizer_TS-3.3.9
zend_optimizer.version=3.3.9
zend_extension=/usr/local/Zend/lib/ZendExtensionManager.so
zend_extension_ts=/usr/local/Zend/lib/ZendExtensionManager_TS.so

Pour PHP6

ZendOptimizer n'est pas supporté actuellement avec PHP6
Lorsque que celui-ci sera supporté, il faudra faire la même opération qu'avec PHP5.